Instant account verification unavailable
Incident Report for Zepto Payments AU
Resolved
The incident has been resolved
Posted May 29, 2018 - 16:51 AEST
Investigating
Our instant account verification is currently unavailable. We are investigating the issue.
Posted May 29, 2018 - 14:42 AEST
This incident affected: Bank Connections and User Interface.